
A Where to learn more
The online help for Cadence OrCAD PCB Designer is poorly organised. There is no way of
searching more than one file at a time for text, which makes it very difficult to solve queries
until you know most of the answer already! The help documents are no more than online
versions of the manuals, which are supplied as pdf files – over 100 of them. Unfortunately
their names are cryptic so it isn’t even easy to work out which to read, and the interdocument
links have been set up in a way that works only on unix. Here is a guide to the most helpful
documents with their filenames (all have the extension .pdf). The documentation is not entirely
consistent with our version of PCB Editor.

• The OrCAD Flow Tutorial (flowtut) takes you through the complete process of capture,
simulation and PCB design and covers several techniques that I have not described in
these notes.

• OrCAD Capture User’s Guide (cap_ug) has a particularly relevant chapter on Using Cap-
ture with PCB Editor, which includes issues such as assigning the No Connect property.

• PSpice User’s Guide (pspug)

• The Allegro PCB Editor User Guide (algromast) is the most helpful set of documents for
this piece of software but is so long that it is split into 12 further documents, of which
these are most relevant:

1. Getting Started with Physical Design (algrostart). This is the most useful document
for learning how to use Allegro, much better than the tutorial.

2. Defining and Developing Libraries (algrolibdev)

3. Transferring Logic Design Data (algrologic) – despite the name, this means import-
ing from Capture or a similar application and includes analogue components.

4. Preparing the Layout (algrolay)

5. Creating Design Rules (algrodesrls)

6. Placing the Elements (algroplace)

7. Routing the Design (algroroute)

8. Completing the Design (algrodescmp)

9. Preparing Manufacturing Data (algroman)

You might also need the Allegro Constraint Manager User Guide (cmug). The Allegro
PCB Editor Tutorial (algrotutorial) concentrates on the user interface and doesn’t tell you
how to do much.

• Routing is explained in the Autorouting with Allegro PCB Editor Tutorial (aleg_spec_-
tut), which concentrates on routing from PCB Editor, both manual and automatic. The
Allegro PCB Router Tutorial (sptut) explains routing within SPECCTRA itself, for which
the complete reference is Allegro PCB Router User Guide (spug).
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Figure A-1  Allegro PCB Editor Toolbar Icons

The command mapping in Table A-1 lists the menu choices that can be found in the different
modes (Layout and Symbol) of Allegro PCB Editor. If you are running a different product in
the Allegro family (for example, PCB Design 220), some commands listed here might not be
available.

Table A-1  Allegro PCB Editor Command Mapping
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Figure 22. Toolbars in Allegro, taken from the Allegro PCB and Package Physical Layout
Command Reference. Not all of the buttons are available in OrCAD PCB Editor and many
provide functions that I have not described.

• If you know precisely which PCB Editor command is involved, there is a file for com-
mands starting with each letter. They are called A Commands (acoms) to Z Commands
(zcoms). The names of the commands are not always obvious, in which case the Alle-
groPCB and Package Physical Layout Command Reference (cmdrefmast) is the place to
start. The new board wizard is under L (layout wizard), for instance, which confuses me
repeatedly. Figure 22 for the toolbars is taken from this manual.
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B Power-user tips for the future and random jottings
This is a disorganised collection of techniques that I have found useful but seemed too compli-
cated for the body of this handout (which is already far too long).

B.1 Modes of operation
I didn’t dwell on this in the instructions because we would all rather try out the software than
read a lengthy ‘theory of operation’ but here is a little more. The main point is that the tools
in PCB Editor can be used in two different ways (see page 23 of Getting Started with Physical
Design for further details).

• Menu-driven editing mode or verb–noun use model. In this mode you first choose a
command, either from the menu bar or by clicking a button, then the design element on
which the tool should operate.

• Pre-selection mode or noun–verb use model. In this mode you first choose the object
followed by the command, which is usually selected from the contextual menu by right-
clicking.

The verb–noun approach is a little more cumbersome but it is much easier to see what is hap-
pening, particularly if you keep the control panels open. For example, if you choose Add
Connect, the Find panel automatically selects Pins, Vias and so on – the items to which a con-
nection can be added. The Options displays the etch layers available and options for the tracks,
such as width and angle of bends. If the Move command is selected instead, different options
are offered and other classes are activated in Find.

The noun–verb model is often more convenient when you know what you are doing and
want to perform a set of operations on an object. However, there is a huge number of possible
operations and they don’t all fit into a contextual menu. PCB Editor therefore has two Applica-
tion Modes, which can be selected from the menu bar with Setup > Application Mode or with a
button. These are the modes.

• General Edit (GEN). This is the most useful mode and is intended for arranging com-
ponents and adding connections.

• Etch Edit (EE). This is mainly for editing tracks that have already been routed.

The current mode is shown near the right-hand end of the status bar below the windows.
The particular set of commands in the contextual menu depends on exactly what is selected.

You may therefore need to adjust the Find control panel before you are able to select the desired
element – a pin for Add Connect, for instance.

Fancier versions of Allegro have a third mode for Flow Planning and there is an empty
space on the button bar for it but it is not available to us.

Use Setup > Application Mode > None to exit from the current application mode and return
to a menu-driven editing mode (there is no button). No contextual menu is available and the
Find control panel is deactivated until a tool or application mode is chosen again. If PCB Editor
appears ‘dead’ there is probably no application mode selected.

If that isn’t enough, there are further shortcuts described on pages 34–35 of Getting Started
with Physical Design. These are the actions that take place by default when you click and drag
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on an object, often while holding a modifier key down, and are the quickest ways of performing
the most common actions. For example, in general editing mode:

• dragging a symbol, text or via moves it

• control-dragging a symbol, text or via duplicates it

• shift-dragging a symbol rotates (spins) it

• dragging a cline segement slides it

Similarly, in etch editing mode:

• dragging a cline segement slides it

• double-clicking a pin or via adds a connection (and this can be shortened further to a
single click with the contextual menu Customize > Enable Single Click Execution)

That should be enough for now!

B.2 Design rules, particularly width of tracks.
The suggested design rules do not permit a track to run between the pads of of an integrated
circuit, 0.1′′ apart. This keeps the board easy to solder but makes it more difficult to route. If
you wish to allow tracks between the pads, reduce the Minimum line to pad spacing to 12 mils
in the New Board Wizard. For an existing design use Setup > Constraints > Spacing. . . to
bring up the Constraint Manager, select Spacing Constraint Set > All Layers and change the
appropriate entries from 20 to 12. You will need to solder the board carefully!

It can be helpful to change the width of a track along its length, particularly if the tracks
are narrow, because our etching process tends to attack long, isolated tracks; keep them at least
20 mil wide. You can change the width during manual routing with the Options control panel
or contextual menu.

B.3 Editing padstacks to include guide holes for drilling
Here’s how to fix the padstacks so that they can be plotted with a guide hole for drilling. The
trick is to use the solderpaste layer for the guide hole. (I’m grateful to redwire and other
members of the Cadence forum for help with this. The procedure should become obsolete with
version 16.2.) See Library Padstacks in Defining and Developing Libraries, Layout Padstacks,
Vias, and Etch Shapes in Preparing the Layout, and Padstack Designer in P Commands for full
details.

1. Right-click on a pin and choose Modify Design Padstack > All Instances. Alternatively,
choose Tools > Padstack > Modify Design Padstack. . . from the menu bar and select a
padstack either by clicking or from the Options control panel. The Padstack Designer
starts.

2. You will probably see the Parameters tab first. There’s probably no need to touch this
unless you want to adjust the diameter of the hole.
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Figure 23. Padstack editor settings with a pastemask to act as a dummy hole.

3. The Layers tab needs the work. See figure 23. I’m not sure what the Thermal Relief and
Anti Pad should be, but these settings avoid complaints.

• The TOP and BOTTOM layers should have the dimensions of the copper under
Regular Pad. It is best to set the Thermal Relief and Anti Pad to null.

• The DEFAULT INTERNAL layer has the same dimensions in all three categories.

• SOLDERMASK_TOP and SOLDERMASK_BOTTOM have the same size Regu-
lar Pad as the others.

• I have edited the PASTEMASK_TOP and PASTEMASK_BOTTOM to have a cir-
cular Regular Pad with diameter 20 mil. This will become the guide hole in the
final plot.

There are further commands to replace padstacks and to purge unused padstacks from a design.

B.4 Alternative design flow
If you don’t like the idea of the new board wizard, you can follow a more conventional but
clumsier flow to start the board. It gives a little more control.

1. Send the netlist from Capture to PCB Editor without first setting up a bare board. Leave
the Input Board File empty in the Create Netlist dialogue box, figure 7 on page 16.
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2. In PCB Editor, use Setup > Outlines > Board Outline to define the outline of the board
and the route and package keepins, which are made identical. The same dialogue box can
be used to change these outlines later. You might wish to draw a different route keepin
with Setup > Areas > Route Keepin.

I have not tried placing the components first and subsequently drawing the board outline
and keepins around them. You would obviously have to keep DRC off.

3. Import a technology file with File > Import > Techfile when we set one up! Until then
you will have to work through the steps below.

4. Use Setup > Cross-section to define the number, names and types of layers. The default
is two layers, which is fine.

5. Set up the grids with Setup > Grids. I suggest 100 mil for the non-etch layers and 25 mil
for the etch.

6. Define the widths of tracks with Setup > Constraints > Physical and the separations with
Setup > Constraints > Spacing. While you are doing this, edit the vias in the Physical
pane as described on page 38.

7. You might wish to tweak some of the parameters in Setup > Design Parameters > Dis-
play, such as the display of drill holes and the ratsnest. Their visibility is treated differ-
ently from other elements of the design. (At present you can display the drill holes on
the screen but not plot them.)

B.5 Miscellaneous PCB Editor tips
There seems to be no Unroute Board command within PCB Editor, which would be helpful if
you made a complete mess of routing. One method is to reload the design, assuming that you
saved it first. Alternatively, try this.

1. Open the Find control panel and select Nets only.

2. Drag across the design to select all the nets.

3. All the nets are now highlighted in the main window. Right-click and choose Ripup etch.

I haven’t described how to produce Gerber files and the like, which require the Manufacture
menu of PCB Editor. This will depend on the demands of the company involved. See Preparing
Manufacturing Data.

It should be possible to set up colour files that make it simpler to produce photomasks. I
haven’t yet got this to work reliably. The colorview commands are described in C Commands.

I haven’t explained how to add mechanical features such as mounting holes, which ought to
be remedied. These can be placed by selecting Place > Manually. . . and choosing Mechanical
symbols from the drop-down list. Click the Advanced Settings tab and choose Library because
these symbols will not be in the database imported from Capture.

I haven’t explained how to do pours (nor have I tried it myself).
Our local allegro library doesn’t yet include mechanical symbols. There is another problem

with the electrical symbols too: the values have vanished. The padstacks have proliferated

46



into a mess too. The main references for this job are Defining and Developing Libraries and
Preparing the Layout. Issues with importing from Capture are covered in Preparing your
design for use with PCB Editor in the Capture UserÕs Guide. The conversion of libraries from
Layout is described under the orcad in command in O Commands.

It would be convenient if the schematic circuit could be drawn once with both ‘virtual
components’ such as sources for simulation and sockets for the real PCB. Unfortunately this
cannot be done without editing the components in the pspice library because some have pins
numbered 0, which allegro rejects. Many of the libraries are full of bugs. Some components
have pins numbered with letters (such as the electrolytic capacitor) and some aren’t numbered
at all.

I find it helpful to adjust the grids produced by the new board wizard, which are the same
for everything. Choose Setup > Grids. . . from the menu bar and change the Spacing figures
for Non-Etch (essentially the components) to 100. Leave the remaining spacings at 25.

Lines in the ratsnest are ‘jogged’ by default. I prefer to join the components with straight
lines instead. Choose Setup > Design Parameters. . . from the menu to bring up the Design
Parameter Editor. Select the Display tab and adjust the Ratsnest geometry to Straight.

There are two types of ‘design’ file that both use the extension .dsn, but whose contents are
entirely different.

• Capture has a design file to hold its database (Windows calls it a Data Source Name)

• PCB Editor uses a design file to export the board to the autorouter.

Don’t let them get mixed up! This is one of the reasons for setting up a separate allegro
subdirectory.

There is a high chance of error if you copy names of footprints from a document and type
them manually: It is better practice to select them from a library. This is a bit clumsy in PCB
Editor. (Perhaps there is a better way that I have yet to discover because this worked better in
Layout. A listing of the directory might be easier.)

1. Choose Place > Manually. . . from the menu bar.

2. Click the Advanced Settings tab and choose to Display definitions from Library.

3. Return to the Placement List and select Package symbols from the drop-down list. You
will now see a list of all packages in the libraries.

4. Scroll down to find the outline that you want, RC400 for example. Click in the check
box next to the component and a graphic appears in the Quickview window. This helps
you to confirm that it is the correct outline, although there is no scale.

5. Select the Text radio button and the name of the component appears. You can copy this
and paste it into the Properties Editor in Capture.

6. Dismiss the Placement box with Cancel when you have finished and quit from PCB
Editor without saving any changes.
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B.6 SPECCTRA tips
Tracks can be edited in SPECCTRA instead of PCB Editor. This is handy for moving badly-
placed vias (I found it easier than PCB Editor). Right-click in the window, which brings up
the INTERACTIVE ROUTING MENU. Move mode is probably the most useful. You can then
select tracks or vias and move them. This is best done before the finishing touches of spreading
and mitring. In fact you can do most of the placement and routing in SPECCTRA but I didn’t
want to describe yet another interface.

If you export a fully or partly routed board from PCB Editor to SPECCTRA, the imported
tracks are protected against changes in SPECCTRA. Choose Edit > [Un]protect > Wires by
Net. . . (or Wires by Layer List. . . ) to remove the protection. You can then unroute these tracks
and reroute the board.
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