Cadence Breadcrumbs
CommunityForums Custom IC SKILL rteGeomSize command is not copying the layers from pcel...

rteGeomSize command is not copying the layers from pcells

Hi, 

I want to copy shapes in lower hierarchy of a cell into top level. I tried using dbGetOverlaps command but its taking a whole lot of time if the database size is larger. I came across a command called rteGeomSize that am using as below. Its working fine and copying all the shapes from all lower hierarchies except the shapes in pcells. 

rteGeomSize(?cv geGetEditCellView() ?lpp1 list("M2" "drawing") ?outputLpp list("M3" "drawing") ?size 0.5 ?trimCorners nil ?fixEdgesToRegion nil ?region cv~>bBox)

Could someone let me know if there is a fix for this issue?

Thanks,

Prasad

  • Prasad,

    It does include the PCells for me. You might also consider the abeLayer* functions too, but I don't see why rteGeomSize wouldn't work.

    Which IC sub-version are you using? I looked back and found a change request I filed in 2008 which was fixed in an early IC6.1.3 subversion (ISR2) which was related to not working where there were pcells, but surely you're not using such an old version (at least not without mentioning it)?

    You might also want to just try specifying ?lpp1 "M2" rather than a layer-purpose.

    Andrew

  • Hi Andrew, 

    Thanks for your reply. I'm using Virtuoso 6.1.8 version. I tried by using "M2", it doesn't work. and I tried with "M2 drawing" as well. Not just the pcells, this command is not copying some instances as well. 

    I'll try to use abeLayer functions. I'm actually trying to create a ptap guardring around prBoundary with all metals from M1 to M6 along with vias. If there are metals routed to the boundary edges (for pins), I want to chop that particular metal layer in guardring. I'm able to do this operation by using dbGetOverlaps and then copying the layers into top level, dbSize the copied layers and then dbLayerAndNot operation. The script is working fine on small cells. But if the database is large (say 1mm X 1mm), its taking a whole lot of time to execute. So, I'm looking for ways to finish the job quickly and I came across this function rteGeomSize. Could you please let me know if there is any function that is faster than the functions that I mentioned above. Thanks in advance. 

    Thanks,

    Prasad

  • Hi Prasad,

    The abe functions (and I think the rte functions) should be fast as they are designed to be quick and work cross-hierarchy (the abe functions are newer).

    If it's not working, please contact customer support as we need to understand what is going wrong. As I said, it's working for me so maybe there is some peculiarity with your data. Note that the abe functions are restricted to shapes with 45 degree angle multiples. I think the rte functions might be restricted to orthogonal (90 degree multiple) shapes only - perhaps that's your issue?

    Andrew

  • Andrew, 

    rte command is failing for orthogonal shapes only. I dont have any 45 degree angled shapes in my database. Let me contact the customer support. 

    While coming to the abe commands, could you please provide me an example of how to use this function. I'm trying to use abeLayerSize function but its expecting ID of input and output layers. What am I supposed to provide here? As I mentioned before, I need a command to extract the layout and get the database ID by itself. 

    Thanks,

    Prasad

  • abeInit(cv)
    M2=abeLayerFromCellView("M2")
    outLay=abeNewLayer()
    abeLayerSize(M2 outLay 0.5)
    abeLayerToCellView(outLay "M3")
    abeDone()

    Andrew

Related